I succeeded on my now-retired 2010 HTC Desire.

After much searching any many dead ends, i found Revolutionary

turn on USB debugging (settings | applications | development )
download and unzip revolutionary, cd to the directory it’s in
sudo ./revolutionary
(you have to run it as superuser because it switches some USB drivers in and out while the phone reboots)

I tried this on an HTC Wildfire, and didn’t quite succeed (maybe with another couple of hours, or another couple of updates??)
HTC Wildfire (buzz-1.01.0002, Android: 2.2.1, ROM version: 2.38.841.1)
First I had to downgrade to buzz-1.01.0001, which is the version without the Telstra (or whoever else) branding and special useless apps.
i followed the goldcard instructions here:

as superuser (because adb needs to load and unload modules)

run all the adb commands in step1.bat

you’ve already made a goldcard, so don’t worry about the GoldCardTool.exe step

run all the commands in step2.bat

it’ll fail on the second last one:

fastboot flash zip rom.zip

because telstra have special software and special hardware and special branding and everything.  i even tried the official HTC rom with the older hboot:

fastboot flash zip ../../RUU_Buzz_Froyo_HTC_WWE_2.22.405.1_Radio_13.55.55.24H_3.35.20.10_release_160191_signed.exe
sending ‘zip’ (135564 KB)…
OKAY [ 22.908s]
writing ‘zip’…
(bootloader) signature checking…
FAILED (remote: 12 signature verify fail)


back to the official HTC developer site, resign myself to plug my linux-based phone into a windows machine, install the HTC sync drivers, download and run PG7612000_Marvel_hboot_1.09.0099blahblahblah0214.exe

it finds the phone and offers to update the ROM version from 2.38.841.1 to 1.52.841.2

but no.  ERROR (130) MODEL ID ERROR

next good idea:

do all the steps, upgrade the telstra firmware (the only one that works)

then see if it will let you get the token for htcdev